default.nix 669 B

12345678910111213141516171819202122232425262728293031323334353637
  1. { jacobi ? import
  2. (
  3. fetchTarball {
  4. name = "jpetrucciani-2022-08-17";
  5. url = "https://github.com/jpetrucciani/nix/archive/9e8f5c0b0f7f69257f7ff1c2032cbadbc3da7d25.tar.gz";
  6. sha256 = "1vyjwlhbqxfmm4xpvwyzvdl8k5jd5wg83avxlwpjkfh8yndm0bny";
  7. }
  8. )
  9. { }
  10. }:
  11. let
  12. inherit (jacobi.hax) ifIsLinux ifIsDarwin;
  13. name = "bucketstore";
  14. tools = with jacobi; {
  15. cli = [
  16. jq
  17. nixpkgs-fmt
  18. ];
  19. python = [
  20. (python310.withPackages (p: with p; [
  21. boto3
  22. # dev
  23. moto
  24. pytest
  25. pytest-cov
  26. tox
  27. ]))
  28. ];
  29. };
  30. env = jacobi.enviro {
  31. inherit name tools;
  32. };
  33. in
  34. env